01531 631 533
1 replies
4939 views

radiators are not working on the ground floor but are on on full on the upper two floors.

Posted on 17/11/2012 10:30am
propinquity

JAGA radiators are completely cold on the ground floor (despite the thermostat being on full) yet the same radiators connected to the same DRAYTON LP722 controller and OSO Indirect 210 Boiler, are all working on the upper floors. I am not a plumber just trying to solve for myself. thanks for any ideas.


1 Replies
  • AndyW_JagaUK
    Commented on 05/01/2011 1:00pm

    The first thing to check is the water temperature to the radiators. If they are not working it would suggest there is no hot water there. If this is the case then the system needs to be balanced (i.e. some of the radiators upstairs to be closed slightly to force the water around the rest system)
    Is the pump running at a suitable speed to supply the entire system?
    Have the radiators been bled of all the air?

    These are a few things to check first. If you wish to give us a call please feel free to do so

    Regards

    Andy W
    Jaga UK


Please complete the form below to ask us about any of our products or their applications and one of our consultants will be in touch with you.



Cookies & Your Privacy

We make use of cookies on this website to store small snippets of information on your computer.

This information is used to provide both a superior experience and also provide us with anonymous information about how visitors use our website.

Dismiss Find out more